mixi-exheres

An unofficial repo for exherbo (moved to git://git.exherbo.org/dev/mixi.git).
git clone https://git.shadowice.org/mixi-exheres.git
Log | Files | Refs | README

commit b64874017394d3e66edbf90c77829b2bfa724404
parent bf69f816facbea51197f64e1b509e047b37106bf
Author: Johannes Nixdorf <mixi@user-helfen-usern.de>
Date:   Thu, 14 Oct 2010 15:56:06 +0200

aria2: bump to version 1.10.4

Diffstat:
packages/net-misc/aria2/aria2-1.10.2.exheres-0 | 57---------------------------------------------------------
packages/net-misc/aria2/aria2-1.10.4.exheres-0 | 57+++++++++++++++++++++++++++++++++++++++++++++++++++++++++
2 files changed, 57 insertions(+), 57 deletions(-)

diff --git a/packages/net-misc/aria2/aria2-1.10.2.exheres-0 b/packages/net-misc/aria2/aria2-1.10.2.exheres-0 @@ -1,57 +0,0 @@ -# Copyright 2010 Johannes Nixdorf <mixi@user-helfen-usern.de> -# Distributed under the terms of the GNU General Purpose License v2 - -require sourceforge - -SUMMARY="A multi-protocel and multi-source cli download manager" - -LICENCES="GPL-2" -SLOT="0" -PLATFORMS="~amd64" -MYOPTIONS=" - ares [[ description = [ Required for async DNS resolving ] ]] - expat [[ requires = [ xml ] ]] - gnutls [[ requires = [ ssl ] ]] - sqlite [[ description = [ Required for Chrome/Firefox cookie support ] ]] - ssl [[ description = [ Required for HTTPS, BitTorrent and Checksum support ] ]] - xml [[ description = [ Required for Metalink and XML-RPC support ] ]] -" - -DEPENDENCIES=" - build+run: - sys-devel/gettext - sys-libs/zlib - ares? ( net-dns/c-ares[>=1.5.0] ) - sqlite? ( dev-db/sqlite:3 ) - ssl? ( - app-misc/ca-certificates - gnutls? ( - dev-libs/gnutls[>=1.2.9] - dev-libs/libgcrypt[>=1.2.2] - ) - !gnutls? ( dev-libs/openssl ) - ) - xml? ( - expat? ( dev-libs/expat ) - !expat? ( dev-libs/libxml2[>=2.6.24] ) - ) - test: - dev-cpp/cppunit[>=1.12.0] -" - -src_configure() { - econf \ - --enable-epoll \ - --enable-nls \ - --enable-threads=posix \ - --with-libz \ - $(option_enable ssl bittorrent) \ - $(option_enable xml metalink) \ - $(option_with ares libcares) \ - $(option_with expat libexpat) \ - $(option_with gnutls) \ - $(option_with sqlite sqlite3) \ - $(option_with ssl ca-bundle /etc/ssl/certs/ca-certificates.crt) \ - $(option ssl && option_with !gnutls openssl || echo --without-openssl) \ - $(option xml && option_with !expat libxml2 || echo --without-libxml2) -} diff --git a/packages/net-misc/aria2/aria2-1.10.4.exheres-0 b/packages/net-misc/aria2/aria2-1.10.4.exheres-0 @@ -0,0 +1,57 @@ +# Copyright 2010 Johannes Nixdorf <mixi@user-helfen-usern.de> +# Distributed under the terms of the GNU General Purpose License v2 + +require sourceforge + +SUMMARY="A multi-protocel and multi-source cli download manager" + +LICENCES="GPL-2" +SLOT="0" +PLATFORMS="~amd64" +MYOPTIONS=" + ares [[ description = [ Required for async DNS resolving ] ]] + expat [[ requires = [ xml ] ]] + gnutls [[ requires = [ ssl ] ]] + sqlite [[ description = [ Required for Chrome/Firefox cookie support ] ]] + ssl [[ description = [ Required for HTTPS, BitTorrent and Checksum support ] ]] + xml [[ description = [ Required for Metalink and XML-RPC support ] ]] +" + +DEPENDENCIES=" + build+run: + sys-devel/gettext + sys-libs/zlib + ares? ( net-dns/c-ares[>=1.5.0] ) + sqlite? ( dev-db/sqlite:3 ) + ssl? ( + app-misc/ca-certificates + gnutls? ( + dev-libs/gnutls[>=1.2.9] + dev-libs/libgcrypt[>=1.2.2] + ) + !gnutls? ( dev-libs/openssl ) + ) + xml? ( + expat? ( dev-libs/expat ) + !expat? ( dev-libs/libxml2[>=2.6.24] ) + ) + test: + dev-cpp/cppunit[>=1.12.0] +" + +src_configure() { + econf \ + --enable-epoll \ + --enable-nls \ + --enable-threads=posix \ + --with-libz \ + $(option_enable ssl bittorrent) \ + $(option_enable xml metalink) \ + $(option_with ares libcares) \ + $(option_with expat libexpat) \ + $(option_with gnutls) \ + $(option_with sqlite sqlite3) \ + $(option_with ssl ca-bundle /etc/ssl/certs/ca-certificates.crt) \ + $(option ssl && option_with !gnutls openssl || echo --without-openssl) \ + $(option xml && option_with !expat libxml2 || echo --without-libxml2) +}